Posts Tagged ‘SharePoint 2013; SQL Server Reporting Services 2013’

SQL Server Reporting Services (SSRS) 2012 Service not appearing in SharePoint 2013 Central Administration

October 7, 2013

This caught me out when I was installing SSRS in SharePoint mode on my SharePoint 2013 lab.

I have three servers in my sharepoint farm, SP-MAIN with web and central admin, SP-APP for app and search, and SP-DB for my database components. SharePoint 2013 was installed and working on all servers and I wanted to install SSRS 2012 on my SP-APP application server.

I installed the software on SP-APP, everything looked OK, but I couldn’t see the services in Central Admin. I used the Powershell commands:

Install-SPRSService
Install-SPRSServiceProxy
get-spserviceinstance -all |where {$_.TypeName -like "SQL Server Reporting*"} | Start-SPServiceInstance

but it said the SharePoint reporting service was already running. Couldn’t see it in the services for SharePoint, and couldn’t create an application for SSRS.

Solution: Central Admin is only running on my SP-MAIN server, and you need to install the Reporting Services Add-In for it to show up in Central Administration. After running the SQL 2012 install and selecting the Reporting Services Add-In component (and after a required reboot because of some other updates), when I checked the SharePoint services running on my SP-APP server, sure enough there was the “SQL Server Reporting Services Service” started and running.

When I went to the Manage Service Applications page, I now had the option of creating a SQL Server Reporting Services Application.